Information
La version client d'Admin-Consult/Admin-IS qui est installé sur votre PC / serveur Terminal / Citrix se connecte avec la base de données via le profil ODBC. Ce profil ODBC contient toutes les informations nécessaires et se règle automatiquement lorsque vous installez la version client d'Admin-Consult/Admin-IS 2013. Parfois, il est nécessaire que vous complétiez ou corrigiez les informations manuellement.
Symptome
Lorsque vous démarrez Admin-Consult/Admin-IS 2013 vous obtenez un second écran de connexion avec le nom 'Connect to Adaptive Server Anywhere'. Les collègues peuvent cependant ouvrir une session.
Cause
Le serveur ODBC ne trouve pas le serveur ou le service sur le réseau et ne peut donc pas établir une connexion à la base de données.
Solution
Pour vérifier et éventuellement ajuster le profil ODBC, vous pouvez utiliser les étapes suivantes :
Note pour les systèmes 64 bits :
Si votre PC est un système 64 bits, ce qui est souvent le cas, et vous utilisez Admin-DMS, vous devrez également ajuster le profil ODBC 64 bits.
Pour ce faire, répétez toutes les étapes ci-dessus, uniquement à l'étape 3, choisissez "Sources de données ODBC (64 bits)" ou "Sources de données ODBC (64 bits)".
- Allez, via le menu 'Démarrer' de Windows, vers le panneau de configuration ou vers le panneau de contrôle.
- Choisissez l'option 'gestion du système' ou 'outils administratifs'.
- Double cliquez 'Sources de données (ODBC 32-bits)' ou 'ODBC Data Sources (32-bit)'.
- Sélectionnez l'onglet 'DSN système'.
- Sélectionnez Admin-Consult et cliquez sur 'Configurer'. Si le DSN n'existe pas, contacte Syneton pour créer cette DSN manuellement.
- Sélectionnez l'onglet 'Réseau'.
- Cochez TCP / IP, puis insérez IP = xxxx (où xxxx est l'adresse IP du serveur sur lequel la base de données tourne) du serveur . Si un port spécifique pour le service est défini vous devez également le placer. Vous insérez ensuite IP = x.x.x.x: aaaa dans l'onglet. Remarque: Le port est standard, mais peut différer. Votre administrateur ICT peut vérifier le port sur le serveur. Voir l'explication en bas.
- Retournez au premier tab 'ODBC' et cliquez le bouton 'test connection'.
Si vous obtenez le message "Connection Failed ; Invalid user ID or Password" le test est réussi ; la base de données peut être accédée car le nom d'utilisateur et le mot de passe peuvent être validés.
Si celui ne marche pas, ou les parametres ne sont pas correct, Ou le shared folder (voir chez '4 problemes VPN') n'est pas disponible. Demandez assistance a votre informaticien parce que il s'agit d'une problematique de votre reseau informatique. - Cliquez sur OK et fermez la fenêtre des profils ODBC.
- Démarrez Admin-Consult/Admin-IS 2013.
Note pour les systèmes 64 bits :
Si votre PC est un système 64 bits, ce qui est souvent le cas, et vous utilisez Admin-DMS, vous devrez également ajuster le profil ODBC 64 bits.
Pour ce faire, répétez toutes les étapes ci-dessus, uniquement à l'étape 3, choisissez "Sources de données ODBC (64 bits)" ou "Sources de données ODBC (64 bits)".
Note concernant le port utilisé de la base de données Admin-Consult-Admin-IS:
Si vous utilisez un VPN, la définition d'un port après l'adresse IP est obligatoire. Par défaut, ce port est 2638 mais peut différer. En cas de doute, ou lorsque la connexion échoue, votre administrateur ICT peut vérifier cela sur le serveur où la base de données est en cours d'exécution. Voici comment travailler:
- Ouvrir command prompt en tant qu'administrateur
- Utilisez la commande suivante pour trouver le PID (Process ID) de la base de données: tasklist / fi "IMAGENAME eq dbsrv11.exe
- Utilisez la commande suivante pour rechercher le port de ce processus: netstat -ano | findstr 14752> Assurez-vous de remplacer le '14752 par le PID de votre recherche.
- Utilisez la commande suivante pour trouver le PID (Process ID) de la base de données: tasklist / fi "IMAGENAME eq dbsrv11.exe
- Utilisez la commande suivante pour rechercher le port de ce processus: netstat -ano | findstr 14752> Assurez-vous de remplacer le '14752 par le PID de votre recherche.
Configuration specifique pour le VPN
Utilisation de l'Admin-IS/Admin-Consult via VPN
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