Informatie
De client-versie van Admin-Consult/Admin-IS die geïnstalleerd is op uw pc/terminal server/citrix connecteert via het ODBC-profiel naar de database. Dit ODBC-profiel bevat alle nodige gegevens voor deze verbinding en wordt automatisch ingesteld bij het installeren van de client-versie van Admin-Consult/Admin-IS. Soms is het echter nodig om deze gegevens manueel aan te vullen of te corrigeren. Dit kan bijvoorbeeld het geval zijn wanneer u over VPN vanop afstand wilt inloggen in het pakket.
Symptomen
Bij het opstarten van Admin-Consult/Admin-IS krijgt u een tweede inlogscherm met als naam 'Connect to Adaptive Server Anywhere'. Uw collega's kunnen echter wel inloggen.
Oorzaak
Het ODBC-profiel kan de server of service niet terugvinden in het netwerk en kan daardoor geen verbinding maken met de database.
Oplossing
Voor het nakijken en eventueel aanpassen van het ODBC-profiel kan u onderstaande stappenplan gebruiken:
- Ga via het Windows Start-menu naar het configuratiescherm of Control panel.
- Kies de optie 'Systeembeheer' of 'Administrative Tools’. Of Windows zoeken en typ 'odbc'
- Dubbelklik op 'ODBC Gegevensbronnen (32-bits)' of ‘ODBC Data Sources (32-bit)’ of de 64 bit variant voor Admin-DMS of andere 64 bit toepassingen.
- Selecteer het tabblad 'Systeem-DSN' of ‘System DSN’.
- Selecteer Admin-Consult en klik op 'Configureren' of ‘Configure’. Indien deze DSN niet bestaat, maakt u een nieuw profiel aan met deze naam + stuurprogramma SQL Anywhere 11. Bij tab 'database' zet u bij 'server name' > dbserver = default.
- Ga terug naar de eerste tab 'ODBC' en kies daar rechtsonder voor 'test connection'.
Indien u de melding krijgt "Connection Failed; Invalid user ID or Password" is de test geslaagd; de database kan bereikt worden want username & password kunnen worden gevalideerd. Indien deze faalt , dan zijn ofwel de parameters verkeerd:- Network : Selecteer het tabblad 'Network'. Vink TCP/IP aan en plaatst vervolgens IP=x.x.x.x:2638 (Waarbij x.x.x.x het ip-adres van de server is waar de database op draait en 2638 het poortnummer) in het respectievelijke veld. Note: De poort 2638 is standaard, maar kan afwijken. Uw ICT-beheerder kan de poort nakijken op de server. Zie uitleg onderaan.
- Serve name van de database, : Selecteeer tab 'database' . Daar staat de default 'dbserver' De juiste naam is terug te vinden op de database server. Open hiervoor Windows services. Navigeer naar de regel dis start met 'SQL Anywhere' de naam achter het liggend streepje is de servername die moet ingevuld worden ipv 'dbserver'. Ofwel is de shared folder (Zie verder bij 'problemen VPN) , niet beschikbaar. Vraag raad aan uw ICT beheerder aangezien dit netwerk specifieke zaken zijn.
- Bij succesvolle connectie > Klik op OK en sluit het scherm van de ODBC-profielen.
- Start Admin-Consult/Admin-IS.
Opmerking voor 64-bit systemen:
Indien uw pc een 64-bit systeem is, wat tegenwoordig vaak het geval is en u maakt gebruik van Admin-DMS, dan gaat u ook het 64-bit ODBC profiel dienen aan te passen.
U gaat hiervoor alle bovenstaande stappen herhalen, enkel bij stap 3 kiest u voor 'ODBC Gegevensbronnen (64-bits)' of ‘ODBC Data Sources (64-bit)’.
Opmerking i.v.m. gebruikte poort van Admin-Consult-Admin-IS database:
Indien u via VPN werkt is het definiëren van een poort na het IP-adres verplicht. Standaard is dit poort 2638 maar kan afwijken. Bij twijfel of wanneer de connectie bij opstart niet lukt kan uw ICT-beheerder dit nakijken op de server waar de database op draait. Zo gaat u te werk:
Opmerkingen
0 opmerkingen
Artikel is gesloten voor opmerkingen.